New to Sushiswap, already need help

So, I’m using Metamask with my Ledger on Sushiswap, trying to exchange SNX for RUNE. I keep getting this error message when I try to confirm the swap: Swap failed: Error: EthAppPleaseEnableContractData: Please enable Contract data on the Ethereum app Settings

I’ve entered the contract address for everything Metamask gives me the option to do so. Any help is much appreciated.

Can you enable 'Contract data’ under the Ethereum app Settings?

Then clear cache in app: settings > help > “clear cache”

Any good?

Thanks for the reply. I figured out how to enable ‘Contract data’, and it worked fine without clearing the cache. Transaction completed and everything is on the Ledger, so I’m good to go.

1 Like

It is a security setting in Ledger requiring the user to activate dApp support. Can totally understand that this can be confusing.