Staked SUSHI tokens no longer connected to MyEtherWallet

I staked my SUSHI tokens via MyEtherWallet when I first started. I recently created a MetaMask Wallet and somehow this is now the default. I can no longer access my staked SUSHI tokens. I can only connect SushiBar to the MetaMask wallet as an option. Please help.

same thing happened to me yesterday

Replied to you in another of your posts:
This should be easy to resolve.
In the top left, if you click ‘connect to wallet’ you should be able to select a different wallet.
Your myetherwallet is on your phone right?

If so, if you click ‘WalletConnect’ that should give you a qr code you can scan and connect your wallet.
Give me a shout if that doesn’t work out.

Thank you so much for your reply. I have tried connecting MyEtherWallet mobile app on my cell phone via WalletConnect QR Code several times already over the past few days, but with no success unfortunately. For some reason, MyEtherWallet mobile app on my cell phone does not recognize the WalletConnect QR code. Any other ideas?

Alright, so I tried out using myetherwallet, and yea I see what you are talking about.

It doesn’t look like walletconnect currently supports myetherwallet. What you could do is recover your eth account in metamask or another wallet using your seed phrase. This would have a different wallet software connect to your eth wallet.

Then you could connect to sushiswap, etc.
I’m a big fan of metamask, and you could use the phone app if you prefer using your phone.

Also to verify your SLP tokens in your eth wallet address, take your eth address and add it to

You can then view the portfolio of your wallet.

Good luck!

Thank you! I tried importing MyEtherWallet (MEW) to MetaMask wallet, but I don’t have the JSON file or Private Key with MEW. MEW only offered the seed phrase which I have, but it’s not an option for importing. Do you have any recommendation on a different software wallet to connect to MEW?

If you have the seed phrase, lock your metamask, then you can import the seed phrase of your other eth account.

I have tried importing MEW to MetaMask wallet using the MEW seed phrase, but it doesn’t work. With MetaMask wallet, I can only import with a Private Key or a JSON File. Since MEW only offered a Seed Phrase which I have (no private key or JSON file), I am totally baffled on how to reconnect MEW to SushiBars, so I can access my staked Sushi. What a dilemma!

Lock your metamask by clicking here:

Then you can import with seed phrase here:

You may also want to check out your eth account SLP at

You can view what tokens you have staked to your eth account there.

Good luck!

I have a 24-word seed phrase for MyEtherWallet and MetaMask only takes 12-word seed phrase unfortunately.

. Yes, I also have and I can see my staked Sushi tokens. However, I still have no access to unstake them or send them elsewhere. I am truly grateful for your time and effort in helping me and I wish you fortune and health for your kindness.

Wait. Just tried it again and took the 24-word phrase. You are a genius! More to follow…

Dear Icedcool, you have resolved my issue and I am forever grateful. THANK YOU!!! I was able to reconnect MEW with MetaMask via Chrome browser on my PC which I understand now is also different than my MetaMask wallet on my cell phone. You are a GENIUS and a wonderful person for taking time out of your business day to help a stranger. I wish you lots of happiness, heath and fortune moving forward my friend. Again, thank you and take good care!

1 Like